Application and Skills Assessment Process


Our new skills assessment can be found at http://nuance.mttest.com. If you are currently in the process of completing your test on this site, you can log in below and finish your test. If you have not yet signed up to take a test, please go to our new site to sign up and begin the assessment.

Exam Overview:

Welcome to the Encompass Medical Transcription application and skills assessment site! You will now begin the application and testing process.

One of the most important factors in any employee's job success is proper job placement. The questions regarding your training and experience and the transcription skills assessment will help us to determine the position level and work schedule that are most appropriate for you.

While you are not limited in the amount of time allotted to take the pre-employment tests, you should plan on setting aside at least one full hour to complete all portions of the application process.



Javascript must be enabled to use this site.

Please enable Javascript then refresh this page or click here to continue.

To enable Javascript:

  • Internet Explorer 6 and 7
    1. Click Tools then Internet Options... from the main menu.
    2. Select the Security tab a the top of the Internet Options windows.
    3. Select the Internet icon from the list of zones at the top of the Security options.
    4. Click "Custom level..."
    5. Scroll down to Active Scripting.
    6. Under Active Scripting click Enable.

  • Mozilla Firefox 1.5 and 2.0
    1. Click Tools then Options... (or Firefox then Preferences on the MAC) from the main menu.
    2. Select the Content button at the top of the window the appears.
    3. Click the box by Enable Javascript to put a checkmark in it.

  • Safari
    1. Click Safari then Preferences from the main menu.
    2. Select the Security tab.
    3. Click Enable JavaScript to put a checkmark by it.



System Requirements to Complete This Evaluation:
  • Browser Requirements
  • *** Internet Explorer 9 and Google Chrome are NOT compatible with this testing platform. Internet Explorer 9 won't let you install versions 7 or 8. If you have IE 9, you will need to install both Firefox and Quicktime and then open Firefox (see links below or the FAQ). ***
  • Operating System Requirements
    • Windows XP, or Windows Vista, or Windows 7
    • or
    • Mac OS X 10.4 or newer (10.5 or newer suggested)
  • Javascript must be enabled. This is enabled in most browsers by default.
  • Hardware Requirements
    • Speakers/headphones to hear audio dictations